Weird issue with mphb_availability_calendar

  • This topic has 7 replies, 3 voices, and was last updated 5 months ago by Andre Flores.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1107129
    Fenton Shoemake
    Participant

    I have three accommodations. 1 cabin and 2 rv sites. When I try to call for the calendar by the id number, the rv calendars do not render on the screen however, if I use the id number of the cabin, the calendar renders on the screen…. Any ideas of where to look?

    #1107678
    Andre Flores
    Moderator

    Hello Fenton,

    Are your rv sites added as accommodation types or accommodations? It should be mentioned that only accommodation type ID’s can be used in the shortcode, not the accommodation ones.
    Also, the calendar might be not displayed because of missing or improperly configured rates, make sure rates are set up properly for your rv sites.

    Regards,
    Andre

    #1107999
    Fenton Shoemake
    Participant

    Each RV site is it’s own accommodation type. Only one calendar will render on the page at a time. If I place one calendar at a time on the page, it works. If I place both, only site 1 renders…

    #1108538
    Andre Flores
    Moderator

    Hello Fenton,

    I assume you are trying to include several ID’s in the [mphb_availability_calendar] shortcode, which will not work, as only one ID is accepted in the shortcode. If you would like to have several accommodation type calendars displayed on the same page, you will need to add a shortcode for each of them.

    Regards,
    Andre

    #1295513
    David Mussard
    Participant

    Hi,

    I meet the same problem. Indeed I added the shortcode [mphb_availability_calendar id=”195″] to a shortcode module. I use the ID of the accommodation type not the accommodation itself. But it still doesn’t work. Help please.

    Regards,
    David

    #1296202
    Andre Flores
    Moderator

    Hello David,

    That is correct, you should include the ID of accommodation type and not the accommodation itself. Provide me with the URL to the page in question and temporary access to WordPress Dashboard in a private reply, so I take a closer look at the issue.

    Regards,
    Andre

    #1296214
    David Mussard
    Participant

    I don’t know why but it worked today. I don’t think I changed anything. Thank you for your reply.

    #1296478
    Andre Flores
    Moderator

    Hello David,

    Perhaps that was a caching issue. Anyway, I am glad it works fine now.
    Do not hesitate to contact us back in case further issues arise.

    Regards,
    Andre

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.