some customers email are not translated

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #1353500


    Our site is in two language, French by default and english.

    I have translated the emails strings with WPML.
    The confirmation reservation is made by administrator.
    If i do a reservation in english the first automatic email “pending reservation” it’s well translated in English. But if i want to send the request payment email manualy or if i put the request payment link in the approuved reservation who’s triggered automatically when the administrator put the reservation status on “confirm” : the email are not translated in English, they are in French, but the “payment request link” send to the good english payment page. 

    I don’t know why this occure but it’s a really big problem for us.

    Can you help me ? 

    J. Davis


    Thanks for contacting us. You follow the steps below:

    – navigate to WPML > String Translation and search for the strings of the email template where translation does not work
    – delete such strings
    – visit the editor of the email template on the default language and save the changes
    – go back to WPML > String Translation and try to add translation again.
    – check if the translated email is sent when the property is booked in a secondary language.

    Additionally, the language of the email may depend on the language of the admin’s profile when it is submitted manually. So you may try to navigate to Profile settings and change the language. Then send an email manually.

    Let me know if any tip was helpful.

    best regards,
    J. Davis

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.