Font awesome Icon not showing

  • This topic has 6 replies, 2 voices, and was last updated 2 weeks ago by J. Davis.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1318483
    Sven Grossenbacher
    Participant

    Hi,

    I tried to change a font-awesome icon but it does not show.

    You can check the icon here in the Details of each search result: Pool

    Thanks for having a look at it – can’t figure what is wrong 🙂

    #1319828
    J. Davis
    Keymaster

    Hi Sven,

    It looks like this icon was added since FontAweome v5.1.0 while there is enqueued 4.7.0 version in the theme. You may try to install the Font Awesome plugin to add support for later versions of the Font Awesome icons. Let me know if it is helpful.

    best regards,
    J. Davis

    #1319881
    Sven Grossenbacher
    Participant

    Hi,
    Thanks.

    But in the source code of the theme we have both Font Awesome 4.7 and 5.15.3… maybe they should clean that up…anyway:

    The pool icon shows on the homepage below the title Charco del Palo Apartments (in the apartment panels):
    Pool
    Here we use this code:

    .mphb-loop-room-type-attributes li.mphb-room-type-facilities::before {
        content: "\f5c5";
        font-family: "Font Awesome 5 Free" !important;
    }

    Why does it not show in the search results:
    no pool

    Where the same code is used:

    .mphb-loop-room-type-attributes li.mphb-room-type-facilities::before {
        content: "\f5c5";
        font-family: "Font Awesome 5 Free" !important;
    }

    See they have the same css code but still…

    Any idea?

    Thanks

    #1320568
    J. Davis
    Keymaster

    Hi Sven,

    I’ve checked the source code of the Home and Search results pages and I’ve found that on the Home page there is enabled Font Awesome 5.15.3 while on Search Results, there is enabled Font Awesome 4.7.0. You need to enable Font Awesome 5 globally for your site. You may navigate to the settings of Elementor and try to switch its option for the support of Font Awesome.

    best regards,
    J. Davis

    #1320617
    Sven Grossenbacher
    Participant

    Hi,

    Font Awesome is enabled in Elementor. And it uses Font Awesome 5. I also activated the setting for Font Awesome 4 support in Elementor.

    However it seems the Alpenhouse template or the head of the template only has FA 4.7 and Elementor can’t change that…just my thought that maybe something should be updated on the Alpenhose theme?

    Do you have another suggestions?

    Thanks

    #1320888
    J. Davis
    Keymaster

    Hi Sven,

    Thanks for your question. Yes, we have such a request in our list of features to update the version of the Font Awesome in the theme . Meanwhile, the installation of the Font Awesome plugin may be helpful https://wordpress.org/plugins/font-awesome/ Please try to install this plugin on your site to enable Font Awesome 5 globally.

    best regards,
    J. Davis

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.