Critical error on booking. Can’t go through booking confirmation page

Free and Premium WordPress Plugins & Themes Forums WordPress Plugins Hotel Booking Critical error on booking. Can’t go through booking confirmation page

  • This topic has 1 reply, 2 voices, and was last updated 2 months ago by J. Davis.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1549996
    liz jao
    Participant

    Hi, I transferred my website to a new hosting but now my customers can’t continue their booking. It says “There has been critical error on this website”.

    But I can book perfectly on my end with my pc.

    Error on logs:
    HP Deprecated: class_exists(): Passing null to parameter #1 ($class) of type string is deprecated in /home/username/public_html/wp-content/plugins/woocommerce/includes/wc-core-functions.php on line 2101
    [28-Dec-2023 07:31:15 UTC] PHP Deprecated: Return type of MPHB\Libraries\WP_SessionManager\Recursive_ArrayAccess::offsetExists($offset) should either be compatible with ArrayAccess::offsetExists(mixed $offset): bool, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /home/username/public_html/wp-content/plugins/motopress-hotel-booking/includes/libraries/wp-session-manager/class-recursive-arrayaccess.php on line 88
    [28-Dec-2023 07:31:15 UTC] PHP Deprecated: Return type of MPHB\Libraries\WP_SessionManager\Recursive_ArrayAccess::offsetGet($offset) should either be compatible with ArrayAccess::offsetGet(mixed $offset): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /home/username/public_html/wp-content/plugins/motopress-hotel-booking/includes/libraries/wp-session-manager/class-recursive-arrayaccess.php on line 101
    [28-Dec-2023 07:31:15 UTC] PHP Deprecated: Return type of MPHB\Libraries\WP_SessionManager\Recursive_ArrayAccess::offsetSet($offset, $data) should either be compatible with ArrayAccess::offsetSet(mixed $offset, mixed $value): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /home/username/public_html/wp-content/plugins/motopress-hotel-booking/includes/libraries/wp-session-manager/class-recursive-arrayaccess.php on line 115
    [28-Dec-2023 07:31:15 UTC] PHP Deprecated: Return type of MPHB\Libraries\WP_SessionManager\Recursive_ArrayAccess::offsetUnset($offset) should either be compatible with ArrayAccess::offsetUnset(mixed $offset): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /home/username/public_html/wp-content/plugins/motopress-hotel-booking/includes/libraries/wp-session-manager/class-recursive-arrayaccess.php on line 137
    [28-Dec-2023 07:31:15 UTC] PHP Deprecated: Return type of MPHB\Libraries\WP_SessionManager\WP_Session::current() should either be compatible with Iterator::current(): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /home/username/public_html/wp-content/plugins/motopress-hotel-booking/includes/libraries/wp-session-manager/class-wp-session.php on line 251
    [28-Dec-2023 07:31:15 UTC] PHP Deprecated: Return type of MPHB\Libraries\WP_SessionManager\WP_Session::next() should either be compatible with Iterator::next(): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /home/username/public_html/wp-content/plugins/motopress-hotel-booking/includes/libraries/wp-session-manager/class-wp-session.php on line 273
    [28-Dec-2023 07:31:15 UTC] PHP Deprecated: Return type of MPHB\Libraries\WP_SessionManager\WP_Session::key() should either be compatible with Iterator::key(): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /home/username/public_html/wp-content/plugins/motopress-hotel-booking/includes/libraries/wp-session-manager/class-wp-session.php on line 262
    [28-Dec-2023 07:31:15 UTC] PHP Deprecated: Return type of MPHB\Libraries\WP_SessionManager\WP_Session::valid() should either be compatible with Iterator::valid(): bool, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /home/username/public_html/wp-content/plugins/motopress-hotel-booking/includes/libraries/wp-session-manager/class-wp-session.php on line 295
    [28-Dec-2023 07:31:15 UTC] PHP Deprecated: Return type of MPHB\Libraries\WP_SessionManager\WP_Session::rewind() should either be compatible with Iterator::rewind(): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /home/username/public_html/wp-content/plugins/motopress-hotel-booking/includes/libraries/wp-session-manager/class-wp-session.php on line 284

    #1550456
    J. Davis
    Keymaster

    Hi,
    I advise you to check if there is the latest version of the Hotel Booking plugin installed on your site and check if PHP version on the customer’s server is 7.4+

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.