Synchronization, wp cron event

  • This topic has 13 replies, 7 voices, and was last updated 4 months ago by Andre Flores.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1136691
    Andrew Coton
    Participant

    Good morning

    I am having trouble syncing my calendars. I have messaged support and they had a look and told me that I am missing “mphb_cron_ical_auto_synchronization”
    file in WP Cron – Event (this plugin is necessary to test the crone).

    Up to this point, I have never had to deal with cron jobs and don’t really know where to start. I am hosting my own server on cloudways and it looks easy enough to add an event, but I really don’t know what information I’m supposed to put where. Could someone give me a clue what my next step should be?

    Many Thanks

    #1138371
    Andre Flores
    Moderator

    Hello Andrew,

    I have checked your dashboard and it looks like the mphb_cron_ical_auto_synchronization event is already there and runs properly. You should insert your OTAs export links to corresponding accommodations under Bookings ->Sync Calendars tab and synchronization should work properly after that.

    Regards,
    Andre

    #1138598
    Andrew Coton
    Participant

    Hello there

    Thank you for having a look and replying. I have set it up to receive the calendars from booking.com, but they are still not accepting the link. The error that I get is “This is not a valid iCal URL. Please try again.”. I have made sure that there are no rogue spaces.

    Do you have any further suggestions?

    Kind Regards

    #1139322
    Andre Flores
    Moderator

    Hello Andrew,

    Make sure your website is not under construction, as synchronization will not work in this case.
    Also, check whether there is at least one booking in your exported .ics file, as Booking.com and some other OTAs do not accept export links with no events in them. If the issue persists, submit a request to our Help Desk providing your website URL and temporary access to WordPress dashboard, so we take a closer look at the issue.

    Regards,
    Andre

    #1157514
    Brian Kollmansberger
    Participant

    I also am having trouble syncing my calendars. I have messaged support and they had a look and told me that I am missing “mphb_cron_ical_auto_synchronization”
    file in WP Cron – Event (this plugin is necessary to test the crone).

    I have never had to deal with cron jobs and don’t really know where to start. I am hosting my own server on siteground and it looks easy enough to add an event, but I really don’t know what information I’m supposed to put where. Could someone give me a clue what my next step should be?

    #1158139
    Andre Flores
    Moderator

    Hello Brian,

    I have just checked your tickets and the issue is resolved now. Just to let others know what has been done to resolve it, I am pasting the copy of the ticket reply below:

    The issue was caused by the fact that mphb_cron_ical_auto_synchronization event did not exist in the events list of WP Crontrol plugin for some reason. I have scheduled a synchronization using “Time” option under Accommodation ->Settings and the event appeared. Now automatic synchronization should work fine.
    Let me know if you have further concerns.

    Regards,
    Andre

    #1254059
    David Y.
    Participant

    Hello Andre,

    We are facing the similar issues:
    mphb_cron_ical_auto_synchronization event did not exist in the events list of WP Crontrol plugin for some reason.

    We are trying to follow your steps to schedule it, but we could not find “Time” option under Accommodation ->Settings, can you please sned me the details how-to schedule it.

    Many Thanks in Advacne.
    David

    #1255960
    J. Davis
    Keymaster

    Hi David,

    Thanks for your question. The whole set of synchronization options is located at the bottom of the General tab under Accommodation > Settings.
    You may try to follow the steps below:

    – navigate to Accommodation > Settings and find settings of synchronization at the bottom of the page.
    – uncheck the option called Enable automatic external calendars synchronization and Save changes
    – then check/activate the same option Enable automatic external calendars synchronization and select a time of the first synchronization by UTC time https://www.timeanddate.com/worldclock/timezone/utc adding + 2 minutes in advance using the Clock option.
    – Save changes and wait for 2 or 3 minutes and then check logs of synchronization (Calendar Sync Status link at the top admin bar) to learn whether the synchronization worked. It is also recommended to clear the logs if there are stored too many recordings.

    best regards,
    J. Davis

    #1256395
    David Y.
    Participant

    Hello John,

    The issue of setting up crone even – “mphb_cron_ical_auto_synchronization” has been resovled after your advices, many thanks for your professional support!

    Best Regards
    David

    #1258937
    J. Davis
    Keymaster

    Hi David,

    You are welcome. I’m happy to know it worked for you.

    best regards,
    J. Davis

    #1297274
    Aditi Mathur
    Participant

    Hello John,

    I am opening up this thread, I am facing the same issue where the CRON job for calendar synchronization doesn’t appear in the CRON events. MY website is already LIVE and have about 15-18 accommodations in there, we got the customer today and realized that they double booked the accommodation as the calendar sync is not working as expected. Your support or direction will be highly appreciated!

    #1298545
    J. Davis
    Keymaster

    Hi Aditi,

    Thanks for your question. Could you please specify if you have followed the steps described on this reply https://motopress.com/forums/topic/wp-cron-event/#post-1255960 ?

    best regards,
    J. Davis

    #1338592
    la clinica TBWA
    Participant

    Hi, i have MPHB working on my site.

    After the plugin update the cron mphb_cron_ical_auto_synchronization does not have action on wp control plugin… the auto sync does not work and i have 9 duplicated bookings on my hotel…https://paste.pics/52c0063c10c62c6d70ce890ad5fe7dbc im worried about the issue

    #1338816
    Andre Flores
    Moderator

    Hello there,

    Try to re-run automatic synchronization cron by setting synchronization time using “Clock” option under Accommodation ->Settings. Once it is done, the cron event should appear in the list of events.

    Regards,
    Andre

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.