I'm getting this error (this.emptySceneDroppable.droppable is not a function.)

Free and Premium WordPress Plugins & Themes Forums WordPress Plugins Content Editor I'm getting this error (this.emptySceneDroppable.droppable is not a function.)

  • This topic has 14 replies, 7 voices, and was last updated 4 weeks ago by J. Davis.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #546846
    Quentin
    Guest

    I am getting the below error when trying to use Visual Builder on any page on my site. No page will load to edit in Visual builder. Any help is appreciated.

    TypeError: this.emptySceneDroppable.droppable is not a function.
    Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
    Platform: Win32

    #547007
    Quentin
    Guest

    I discovered that if I use internet Explorer or Microsoft Edge it works just fine.

    Appears to be Google Chrome Specific with Java.

    #547028
    Quentin
    Guest

    I take that back, the error started happening again in any browser I used. Any help is appreciated.

    #547678
    J. Davis
    Keymaster

    Hi Quentin,

    Check whether there is installed latest version of plugin. At this moment it is 2.2.0-2.4.1. You can get latest version at your account or marketplace where you purchased plugin.

    Check whether it works with new created page. For this to create a new page and launch Visual Builder. If it does not work you can skip to another step.
    If it works go to page(s) where it does not work and check its content for third party scripts, codes, etc. You can also submit a request and we’ll test that page for you.

    Check whether preview for draft pages works correctly. For this add new page, type any word e.g. ‘test’ and click ‘Preview’ button. If you can see the page with word you typed you can skip to the next step. If you can not see the preview of that page it might be incorrectly configured Under Construction mode or .html file in the root folder of your site.

    There might happen a conflict with other plugin or theme. So you can try to disable plugins one by one and test Visual Builder to find the conflict plugin. If it does not work when all plugins are disabled (except Content Editor) you can try to activate another theme.

    Best regards,
    John

    #661257
    Martin Jones
    Participant

    I am getting the exact same error tried all fixes but to no avail, has anyone found a work around for this as I don’t seem to be getting any replies from support at the moment cheers.

    #662328
    J. Davis
    Keymaster

    Hi Martin,

    We’ve faced few cases when FireWall was blocking the required file. We’re trying to find out why it is blocked and provide a solution as soon as it is possible. We’ll post here when get any news on this. Thank you.

    Best regards,
    John

    #662947
    Martin Jones
    Participant

    Thanks John hopefully a fix will be available pretty soon cheers.

    #668554
    Arkadiusz Kaźmierczak
    Participant

    I have the same problem… What now?

    #668863
    J. Davis
    Keymaster

    Hi Arkadiusz,

    We are trying to find out the reason some hosting providers/ firewall services blocks WordPress requests required for Content Editor however they just whitelist IP of site owner without saying how to prevent that. Could you submit a request so we’ll check your WordPress installation and see if the reason of the issue is blocked request.

    best regards,
    John

    #740712
    Brian K Sibanda
    Participant

    This is happening to me now

    #741709
    J. Davis
    Keymaster

    Hello Brian,

    Thank you for notifying us. Do you have an open request? Did you manage to find the error with blocked request link?

    best regards,
    J. Davis

    #783997
    Bonsignore Aurelien
    Participant

    hi all,
    I have this error :
    a.draggable is not a function

    Any idea to resolve this error ?

    Thanks

    #785236
    J. Davis
    Keymaster

    Hi Bonsignore,

    What version of plugin and WordPress are installed at your site? Do you experience the error on certain page/post or all posts/pages?

    best regards,
    J. Davis

    #903252
    Chris Hallgren
    Participant

    Hopefully this helps someone. I’ve been having this problem and was able to resolve it. This is on a site that I’ve had for several years. We don’t make edits very often but recently needed to make some changes. I went to start the Visual Editor and got this error –

    “an internal error occurred during loading Visual Builder. Please submit this data to support team. TypeError: a.draggable is not a function.”

    Here’s my resolution in a nutshell – We host at GoDaddy. GoDaddy’s firewall wants to block some Visual Editor functions. To get past this, I have to whitelist my IP address in the Firewall. Apparently my IP address had changed and so as soon as I whitelisted my new IP address, the Visual Editor worked.

    Best of luck,
    Chris

    #907404
    J. Davis
    Keymaster

    Hi Chris, We highly appreciate your shared experience. Usually that firewall is called Sucuri. Thanks.

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.