text on slide not visible on small screens (cellphone)

Free and Premium WordPress Plugins & Themes Forums WordPress Plugins Slider text on slide not visible on small screens (cellphone)

This topic contains 20 replies, has 2 voices, and was last updated by   J. Davis 1 year, 9 months ago.

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #342520

    Michiel

    Hi,

    Text on my slider on the homenpage is good on bigger screens like laptop but not on small screens like cellphones. you can’t read it because it is so small

    #343030

    J. Davis
    Keymaster

    Hi Michiel,

    Currently we recommend to build another slider specially for mobile devices, place it under main slider and set visibility for mobile devices only. Do not forget to hide main slider for mobile screen size.
    But we also are working on the next version of slider where you will be able to switch screen modes of a single slider and replace the layers according to screen mode.

    Best regards,
    John

    #362018

    Chuck

    John could you be more specific about how to set this up appropriately so something always displays on any device? I’m have problems with a video slide. It shows up as whitespace on my phones and tablets. I think I understand that these smaller devices are set NOT to load video for whatever really important reasons. Please tell me what is true about this.

    I think what you are describing is setting the video slide to only play when it’s a desktop, and create a second slide that will only play on smaller devices like cellphones and tablets. Could you post the parameters that work best, and where to set those parameters in the plugins settings?

    Here is my test site at http://quadrupleprofits.com It’s a TM template. I gotta learn somewhere:-) I’m gonna leave what I have so you can see and advise. Thanks for your time John!

    #362028

    Chuck

    One other thing. How do I set a video slide to play all the way through before it transitions to the next slide?

    #363353

    J. Davis
    Keymaster

    Hi Chuck,

    This is feature of the plugin not to play self-hosted videos at mobile devices. It may take too long to load the self-hosted videos at small devices and increase bounce rate at your website because many visitors do not wish to wait till your website loads. That’s why this option has been disabled.
    You can try to create another slider specially for mobile devices and add YouTube video as a layer.

    Best regards,
    John

    #363673

    Chuck

    John, you described adding a second slider and adjusting the settings so the phone slider plays for phones and the desktop slider plays for desktop users. “Currently we recommend to build another slider specially for mobile devices, place it under main slider and set visibility for mobile devices only.” How do I accomplish setting visibility for mobile only? Which code goes first? Where are these settings in the plugin?

    #363674

    Chuck

    I don’t understand John. Are you saying the Motopress Slider Plugin allows for video, but if you use a video the result is a big white space if someone hits the page from a tablet, or cellphone? Really?!

    #365440

    J. Davis
    Keymaster

    Hi Chuck,

    In order to set a slider to show on certain devices you should go to slider Settings > Appearance and set Visible from/till dimensions. For example you need to set Visible from – 768 or 900 px for mobile slider to show it on tablets and mobile devices. And for desktop slider you should set Visible till – 768 or 900 px to show on desktop screens.
    We’re working on new version of slider where you do not need to create another slider. You will be able to switch between devices and arrange the layers according to dimension.

    Best regards,
    John

    #397537

    Katie

    Hi

    I have tried setting the dimensions on the appearance tab but seems to work when viewing on desktop but you can still view the desktop sliders on the tablet and some of the images will not load.

    Can you please spell out simply how to fully set up each slide for each device as i can’t find this information anywhere and would make life a whole lot easier then me sitting here changing stuff over and over because it just doesn’t work.

    Thanks

    Katie

    #399592

    Steve

    I’m with Katie on this one. I even duplicated the exact settings you guys use on your demo sliders and I still can’t get mobile to work properly.

    Phone : – 767px
    Tablet : 768-991
    Desktop : 992 –

    Originally I was getting nno sliders on mobile. Then if I held the phone horizontal and refreshed, I would get sliders and it would stay like that even went I wnet back to vertical. BUT…each time I would close the site and go back to look, it was gone again. Now when I do it, I get a giant image of the background for the first slider, but when I start to scroll it disapears.

    Please tell me what I’m doing wrong.

    -Steve

    #401137

    J. Davis
    Keymaster

    Hi Steve and Katie,

    First of all make sure you use latest version of plugin. Currently it is 1.3.5. Then check if you have added all the sliders (Mobile, tablet and Desktop) to the page you try to preview. If it is not still helpful you can submit request providing admin login details. We’ll have a closer look at it.

    Best regards,
    John

    #408361

    Andrea

    I’m having the same issue as well on mobile. I have the most updated version but I’m not quite sure what you mean by “Then check if you have added all the sliders (Mobile, tablet and Desktop) to the page you try to preview.” I have to create 3 sliders every time? I thought the slider was responsive? Please provide admin assistance. My patience with this plugin is wearing thin.

    #408493

    J. Davis
    Keymaster

    Hi Andrea,

    We have released an updated version of slider where you do not need to create 3 different sliders any more. You just need to switch between the device modes and re-arrange the layers as you need http://prntscr.com/d511kv Don’t forget to set size of slider (width and height) for each device in slider settings http://prntscr.com/d510bi
    If you can not see slider on mobile devices you should simply go to Slider Settings, switch to Appearance tab and clear Visibility from/till boxes.

    Best regards,
    John

    #408854

    Andrea Arnold

    Like I mentioned above I have the updated version and I’ve maximized the settings for the three types of devices. My slider still shows up as a small thumbnail on mobile devices.

    #409200

    J. Davis
    Keymaster

    Hi Andrea,

    We need to have a closer look at it. Please provide your login details in a request you submitted. Thank you.

    Best regards,
    John

Viewing 15 posts - 1 through 15 (of 21 total)

You must be logged in to reply to this topic.